Dashboard Loading Slowly
Incident Report for Edlink
Resolved
This incident has been resolved.
Posted Aug 15, 2023 - 22:22 UTC
Identified
We identified the cause of the degraded performance to be network congestion. There were some functions in our code that caused the network congestion when hit repeatedly (600 + requests per second for 60+ consecutive seconds) during a short period of time. We will be modifiying the code before close of business so that it can with stand greater traffic without clogging the network.

This portion of the code was unrelated to our core rostering or SSO functionalities.
Posted Aug 14, 2023 - 20:26 UTC
Update
The Dashboard is back to performing as expected. Still identifying the cause of the temporary degraded performance.
Posted Aug 14, 2023 - 18:17 UTC
Investigating
Our Dashboard is loading slowly. No data has been lost and the core API performance is not affected. We'll send more updates as they're available to us.
Posted Aug 14, 2023 - 18:08 UTC
This incident affected: Edlink Core Systems (Edlink Dashboard).